import Foundation
let pattern = ##"<coverpage><image l:href=\"#(.*?)\"/></coverpage>"##
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = ##"<coverpage><image l:href="#cover.jpg"/></coverpage>"##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)