# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\((.*?)\)(\s?)//gmi;t' <<< "(a) b
There are (brackets) somewhere
(aa) adawidojawoi jadwjo awawdi (awidjoawidj)."