const regex = /\((.*?)\)(\s?)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\((.*?)\\)(\\s?)', 'gmi')
const str = `(a) b
There are (brackets) somewhere
(aa) adawidojawoi jadwjo awawdi (awidjoawidj).`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);