#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:<img\s+src="(.*?)"[^.]*?\/?>|<img\s+src="(.*?)"[^.]*?\/?>)"
Local $sString = "<img " & @CRLF & _
"src="https://www.gravatar.com/avatar/3d708481912838187f5340960105bbfd?s=48&d=identicon&r=PG&f=1" alt="" width="24" height="24" class="bar-sm -avatar js-avatar-me">" & @CRLF & _
"" & @CRLF & _
"<img src="https://www.gravatar.com/avatar/3d708481912838187f5340960105bbfd?s=48&d=identicon&r=PG&f=1" " & @CRLF & _
"alt="" width="24" height="24" class="bar-sm -avatar js-avatar-me">" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")