import re
regex = re.compile(r"(?:<img\s+src=\"(.*?)\"[^.]*?\/?>|<img\s+src=\"(.*?)\"[^.]*?\/?>)", flags=re.MULTILINE)
test_str = ("<img \n"
"src=\"https://www.gravatar.com/avatar/3d708481912838187f5340960105bbfd?s=48&d=identicon&r=PG&f=1\" alt=\"\" width=\"24\" height=\"24\" class=\"bar-sm -avatar js-avatar-me\">\n\n"
"<img src=\"https://www.gravatar.com/avatar/3d708481912838187f5340960105bbfd?s=48&d=identicon&r=PG&f=1\" \n"
"alt=\"\" width=\"24\" height=\"24\" class=\"bar-sm -avatar js-avatar-me\">\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")