$re = '/(?:<img\s+src="(.*?)"[^.]*?\/?>|<img\s+src="(.*?)"[^.]*?\/?>)/m';
$str = '<img
src="https://www.gravatar.com/avatar/3d708481912838187f5340960105bbfd?s=48&d=identicon&r=PG&f=1" alt="" width="24" height="24" class="bar-sm -avatar js-avatar-me">
<img src="https://www.gravatar.com/avatar/3d708481912838187f5340960105bbfd?s=48&d=identicon&r=PG&f=1"
alt="" width="24" height="24" class="bar-sm -avatar js-avatar-me">
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);