import Foundation
let pattern = #"(?:<img\s+src="(.*?)"[^.]*?\/?>|<img\s+src="(.*?)"[^.]*?\/?>)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<img
src="https://www.gravatar.com/avatar/3d708481912838187f5340960105bbfd?s=48&d=identicon&r=PG&f=1" alt="" width="24" height="24" class="bar-sm -avatar js-avatar-me">
<img src="https://www.gravatar.com/avatar/3d708481912838187f5340960105bbfd?s=48&d=identicon&r=PG&f=1"
alt="" width="24" height="24" class="bar-sm -avatar js-avatar-me">
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)