package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:<img\s+src="(.*?)"[^.]*?\/?>|<img\s+src="(.*?)"[^.]*?\/?>)`)
var str = `<img
src="https://www.gravatar.com/avatar/3d708481912838187f5340960105bbfd?s=48&d=identicon&r=PG&f=1" alt="" width="24" height="24" class="bar-sm -avatar js-avatar-me">
<img src="https://www.gravatar.com/avatar/3d708481912838187f5340960105bbfd?s=48&d=identicon&r=PG&f=1"
alt="" width="24" height="24" class="bar-sm -avatar js-avatar-me">
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}