const regex = /(?:<img\s+src="(.*?)"[^.]*?\/?>|<img\s+src="(.*?)"[^.]*?\/?>)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:<img\\s+src="(.*?)"[^.]*?\\\/?>|<img\\s+src="(.*?)"[^.]*?\\\/?>)', 'gm')
const str = `<img
src="https://www.gravatar.com/avatar/3d708481912838187f5340960105bbfd?s=48&d=identicon&r=PG&f=1" alt="" width="24" height="24" class="bar-sm -avatar js-avatar-me">
<img src="https://www.gravatar.com/avatar/3d708481912838187f5340960105bbfd?s=48&d=identicon&r=PG&f=1"
alt="" width="24" height="24" class="bar-sm -avatar js-avatar-me">
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}