using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:<img\s+src=""(.*?)""[^.]*?\/?>|<img\s+src=""(.*?)""[^.]*?\/?>)";
string input = @"<img
src=""https://www.gravatar.com/avatar/3d708481912838187f5340960105bbfd?s=48&d=identicon&r=PG&f=1"" alt="" width=""24"" height=""24"" class=""bar-sm -avatar js-avatar-me"">
<img src=""https://www.gravatar.com/avatar/3d708481912838187f5340960105bbfd?s=48&d=identicon&r=PG&f=1""
alt="" width=""24"" height=""24"" class=""bar-sm -avatar js-avatar-me"">
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}