# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^"(*SKIP)(*F)|"([^"]*)"/$1/gm;t' <<< "\"something \"something something\" and then \"something\" something \"\"\""