package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^"(*SKIP)(*F)|"([^"]*)"`)
var str = `"something "something something" and then "something" something """`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}