use strict;
my $str = '"something "something something" and then "something" something """';
my $regex = qr/^"(*SKIP)(*F)|"([^"]*)"/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";