const regex = /^"(*SKIP)(*F)|"([^"]*)"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^"(*SKIP)(*F)|"([^"]*)"', 'gm')
const str = `"something "something something" and then "something" something """`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);