using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^""(*SKIP)(*F)|""([^""]*)""";
string substitution = @"$1";
string input = @"""something ""something something"" and then ""something"" something """"";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}