$re = '/^"(*SKIP)(*F)|"([^"]*)"/m';
$str = '"something "something something" and then "something" something """';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;