re = /^"(*SKIP)(*F)|"([^"]*)"/m
str = '"something "something something" and then "something" something """'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result