#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\u2985[^\u2985\u2986]*\u2986"
Local $sString = "Keep1⦅Delete1a" & @CRLF & _
" ⦅Delete2⦆" & @CRLF & _
"Delete1b⦆Keep2a" & @CRLF & _
"Keep2b⦅Delete3⦆Keep3"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)