const regex = /\u2985[^\u2985\u2986]*\u2986/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\u2985[^\\u2985\\u2986]*\\u2986', 'g')
const str = `Keep1⦅Delete1a
⦅Delete2⦆
Delete1b⦆Keep2a
Keep2b⦅Delete3⦆Keep3`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);