import Foundation
let pattern = #"\u2985[^\u2985\u2986]*\u2986"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Keep1⦅Delete1a
⦅Delete2⦆
Delete1b⦆Keep2a
Keep2b⦅Delete3⦆Keep3
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)