// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\u2985[^\u2985\u2986]*\u2986").unwrap();
let string = "Keep1⦅Delete1a
⦅Delete2⦆
Delete1b⦆Keep2a
Keep2b⦅Delete3⦆Keep3";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}