#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:.*\b(AND(?:\sNOT)?|OR) +)?(\S+:\S+.*)"
Local $sString = "k:v AND k1:v1 AND NOT k2:v2 OR k3:v3" & @CRLF & _
"k:v AND k1:v1" & @CRLF & _
"k:v AND k1:v1 AND NOT k2:v2" & @CRLF & _
"k:v asd asd"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")