import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:.*\\b(AND(?:\\sNOT)?|OR) +)?(\\S+:\\S+.*)";
final String string = "k:v AND k1:v1 AND NOT k2:v2 OR k3:v3\n"
+ "k:v AND k1:v1\n"
+ "k:v AND k1:v1 AND NOT k2:v2\n"
+ "k:v asd asd";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}