package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:.*\b(AND(?:\sNOT)?|OR) +)?(\S+:\S+.*)`)
var str = `k:v AND k1:v1 AND NOT k2:v2 OR k3:v3
k:v AND k1:v1
k:v AND k1:v1 AND NOT k2:v2
k:v asd asd`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}