re = /(?:.*\b(AND(?:\sNOT)?|OR) +)?(\S+:\S+.*)/m
str = 'k:v AND k1:v1 AND NOT k2:v2 OR k3:v3
k:v AND k1:v1
k:v AND k1:v1 AND NOT k2:v2
k:v asd asd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end