$re = '/(?:.*\b(AND(?:\sNOT)?|OR) +)?(\S+:\S+.*)/m';
$str = 'k:v AND k1:v1 AND NOT k2:v2 OR k3:v3
k:v AND k1:v1
k:v AND k1:v1 AND NOT k2:v2
k:v asd asd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);