use strict;
my $str = 'k:v AND k1:v1 AND NOT k2:v2 OR k3:v3
k:v AND k1:v1
k:v AND k1:v1 AND NOT k2:v2
k:v asd asd';
my $regex = qr/(?:.*\b(AND(?:\sNOT)?|OR) +)?(\S+:\S+.*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}