const regex = /(?:.*\b(AND(?:\sNOT)?|OR) +)?(\S+:\S+.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:.*\\b(AND(?:\\sNOT)?|OR) +)?(\\S+:\\S+.*)', 'gm')
const str = `k:v AND k1:v1 AND NOT k2:v2 OR k3:v3
k:v AND k1:v1
k:v AND k1:v1 AND NOT k2:v2
k:v asd asd`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}