# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/"prefix": *".*?"/"prefix": "new prefix"/gm;t' <<< "{
\"token\": \"stuff\"
\"prefix\": \"!\\"\"
}"