using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""prefix"": *"".*?""";
string substitution = @"""prefix"": ""new prefix""";
string input = @"{
""token"": ""stuff""
""prefix"": ""!\""
}";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}