import re
regex = re.compile(r"\"prefix\": *\".*?\"", flags=re.MULTILINE)
test_str = ("{\n"
"\"token\": \"stuff\"\n"
"\"prefix\": \"!\\\"\"\n"
"}")
subst = "\"prefix\": \"new prefix\""
result = regex.sub(subst, test_str)
if result:
print(result)