const regex = /"prefix": *".*?"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"prefix": *".*?"', 'gm')
const str = `{
"token": "stuff"
"prefix": "!\\""
}`;
const subst = `"prefix": "new prefix"`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);