re = /"prefix": *".*?"/m
str = '{
"token": "stuff"
"prefix": "!\\""
}'
subst = '"prefix": "new prefix"'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result