$re = '/"prefix": *".*?"/m';
$str = '{
"token": "stuff"
"prefix": "!\\""
}';
$subst = "\"prefix\": \"new prefix\"";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;