using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=^0{0,100}[^\W0]\w{3,100})\w(?=\w{4,}$)";
string substitution = @"*";
string input = @"0001113033AA55608981
23456237472347823923
00000000090000000000
09008000800060050000
AAAABBBBCCCCDDDDEEEE
0000BBBBCCCCDDDDEEEE";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}