const regex = new RegExp('(?<=^0{0,100}[^\\W0]\\w{3,100})\\w(?=\\w{4,}$)', 'gm')
const str = `0001113033AA55608981
23456237472347823923
00000000090000000000
09008000800060050000
AAAABBBBCCCCDDDDEEEE
0000BBBBCCCCDDDDEEEE`;
const subst = `*`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);