import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=^0{0,100}[^\\W0]\\w{3,100})\\w(?=\\w{4,}$)";
final String string = "0001113033AA55608981\n"
+ "23456237472347823923\n"
+ "00000000090000000000\n"
+ "09008000800060050000\n"
+ "AAAABBBBCCCCDDDDEEEE\n"
+ "0000BBBBCCCCDDDDEEEE";
final String subst = "*";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}