$re = '/(?<=^0{0,100}[^\W0]\w{3,100})\w(?=\w{4,}$)/m';
$str = '0001113033AA55608981
23456237472347823923
00000000090000000000
09008000800060050000
AAAABBBBCCCCDDDDEEEE
0000BBBBCCCCDDDDEEEE';
$subst = "*";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;