import re
regex = re.compile(r"(?<=^0{0,100}[^\W0]\w{3,100})\w(?=\w{4,}$)", flags=re.MULTILINE)
test_str = ("0001113033AA55608981\n"
"23456237472347823923\n"
"00000000090000000000\n"
"09008000800060050000\n"
"AAAABBBBCCCCDDDDEEEE\n"
"0000BBBBCCCCDDDDEEEE")
subst = "*"
result = regex.sub(subst, test_str)
if result:
print(result)