use strict;
my $str = '0001113033AA55608981
23456237472347823923
00000000090000000000
09008000800060050000
AAAABBBBCCCCDDDDEEEE
0000BBBBCCCCDDDDEEEE';
my $regex = qr/(?<=^0{0,100}[^\W0]\w{3,100})\w(?=\w{4,}$)/mp;
my $subst = '*';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";