import Foundation
let pattern = #"(?<=^0{0,100}[^\W0]\w{3,100})\w(?=\w{4,}$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
0001113033AA55608981
23456237472347823923
00000000090000000000
09008000800060050000
AAAABBBBCCCCDDDDEEEE
0000BBBBCCCCDDDDEEEE
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"*"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)