#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?x)((?:[^,]*,){3})([^,]*)(,.*)"
Local $sString = "a,b,c,d,e,f" & @CRLF & _
"1,2,3,4,5,6" & @CRLF & _
"cat,dog,mouse,elaphant,squirrel,wookiee"
Local $sSubst = "$1col 4($2) has been edited$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)