# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
((?:[^,]*,){3})([^,]*)(,.*)
"""
test_str = ("a,b,c,d,e,f\n"
"1,2,3,4,5,6\n"
"cat,dog,mouse,elaphant,squirrel,wookiee")
subst = "$1col 4($2) has been edited$3"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.VERBOSE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.