// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?x)((?:[^,]*,){3})([^,]*)(,.*)").unwrap();
let string = "a,b,c,d,e,f
1,2,3,4,5,6
cat,dog,mouse,elaphant,squirrel,wookiee";
let substitution = "$1col 4($2) has been edited$3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}