re = /((?:[^,]*,){3})([^,]*)(,.*)/x
str = 'a,b,c,d,e,f
1,2,3,4,5,6
cat,dog,mouse,elaphant,squirrel,wookiee'
subst = '$1col 4($2) has been edited$3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result