package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`((?:[^,]*,){3})([^,]*)(,.*)`)
var str = `a,b,c,d,e,f
1,2,3,4,5,6
cat,dog,mouse,elaphant,squirrel,wookiee`
var substitution = "$1col 4($2) has been edited$3"
fmt.Println(re.ReplaceAllString(str, substitution))
}