$re = '/((?:[^,]*,){3})([^,]*)(,.*)/x';
$str = 'a,b,c,d,e,f
1,2,3,4,5,6
cat,dog,mouse,elaphant,squirrel,wookiee';
$subst = "$1col 4($2) has been edited$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;