const regex = /((?:[^,]*,){3})([^,]*)(,.*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?:[^,]*,){3})([^,]*)(,.*)', 'g')
const str = `a,b,c,d,e,f
1,2,3,4,5,6
cat,dog,mouse,elaphant,squirrel,wookiee`;
const subst = `$1col 4($2) has been edited$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);