import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:[^,]*,){3})([^,]*)(,.*)";
final String string = "a,b,c,d,e,f\n"
+ "1,2,3,4,5,6\n"
+ "cat,dog,mouse,elaphant,squirrel,wookiee";
final String subst = "$1col 4($2) has been edited$3";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}