#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([1-9]\d*|0) rows returned\.$"
Local $sString = "0 rows returned." & @CRLF & _
"1 rows returned." & @CRLF & _
"10 rows returned." & @CRLF & _
"1234 rows returned." & @CRLF & _
"01 rows returned." & @CRLF & _
"00 rows returned."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")